SPM Adoption with Swift 5.3

271 responses

For the largest and most complex app you work on, what is holding you back from adopting SPM as your dependency manager?

269 out of 271 answered

1
Some of the dependencies I use do not yet support SPM.
48%/ 131 resp.
2
Changing dependency managers is a big job and it's a low priority.
28%/ 76 resp.
3
Binary resource support was all that was missing. I will migrate to SPM with Swift 5.3.
25%/ 69 resp.
4
CocoaPods/Carthage aren't broken, I see no need to migrate.
23%/ 63 resp.
5
The SPM is missing a feature I need.
15%/ 42 resp.
6
Nothing! I'm already using SPM.
13%/ 35 resp.
7
I do not like the way that SPM works.
8%/ 22 resp.
8
I don't use a dependency manager. I am self sufficient!
1%/ 3 resp.